Degraded Performance
Incident Report for Huntress
Resolved
This incident has been resolved.
Posted Nov 04, 2021 - 15:40 UTC
Identified
We are experiencing data processing delays which may cause slowness in the Dashboard.
Posted Nov 04, 2021 - 14:39 UTC
This incident affected: Management Portal (huntress.io) and Agent Deployment and Communication.