Increased signal processing latency

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 13:03 UTC

Monitoring

Secondary affects from the AWS outage continue to negatively impact processing latencies. Identified issues have been mitigated. We will continue to monitor.
Posted Oct 20, 2025 - 17:06 UTC
This incident affected: Incident Reports.