Portal Web Errors and Agent Communication Delays

Incident Report for Huntress

Resolved

We have shifted resources off of the affected AWS zone and are not seeing any further issues.
Posted May 08, 2026 - 02:27 UTC

Monitoring

We have taken action to mitigate the effects of the AWS outage and are continuing to monitor.
Posted May 08, 2026 - 02:10 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 08, 2026 - 02:09 UTC

Update

Amazon Web Services is experiencing an outage which is impacting our ability to remediate. Investigation is ongoing.
Posted May 08, 2026 - 01:24 UTC

Investigating

We are currently investigating this issue.
Posted May 08, 2026 - 00:49 UTC
This incident affected: Management Portal (huntress.io), Huntress Web (huntress.com), Agent Deployment and Communication, Security Awareness Training, Incident Reports, ITDR, and SIEM.