Increased Portal Latencies for Non-US Users
Incident Report for Huntress
Resolved
This incident has been resolved.
Posted Sep 10, 2024 - 04:12 UTC
Update
We are continuing to investigate this issue.
Posted Sep 10, 2024 - 03:32 UTC
Investigating
We are currently investigating this issue.
Posted Sep 10, 2024 - 03:32 UTC
This incident affected: Management Portal (huntress.io).