Backend Processing Latencies

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted May 16, 2025 - 00:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 15, 2025 - 22:40 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 15, 2025 - 22:22 UTC

Investigating

We are currently observing increased latencies in backend data processing queues that may impact timely detections and reporting
Posted May 15, 2025 - 21:03 UTC
This incident affected: Incident Reports, MDR for Microsoft 365, and SIEM.