Page Load Failures in Australia, New Zealand

Incident Report for Huntress

Resolved

This incident has been resolved.
Posted Jul 02, 2026 - 02:28 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 02, 2026 - 01:55 UTC

Update

We are continuing to investigate this issue.
Posted Jul 02, 2026 - 01:39 UTC

Investigating

We are currently investigating an issue affecting the management portal for users located in Australia, New Zealand, and the surrounding Oceania region
Posted Jul 02, 2026 - 00:57 UTC
This incident affected: Management Portal (huntress.io).